Account creation problems
Incident Report for Notificare
Resolved
We have identified the problem with account creation and deployed a fix that corrects this issue. You should now be able to create accounts without any other hiccups.
Posted Mar 06, 2019 - 19:54 CET
Investigating
We are currently investigating this issue, we will provide more information as soon as possible.
Posted Mar 06, 2019 - 13:07 CET
This incident affected: Notificare APIs and Dashboard, Website, Documentation and Support Portal.